SMS delivery delay to US carriers

Incident Report for Keeper Status Page

Resolved

This incident has been resolved.
Posted Apr 29, 2021 - 18:33 PDT

Update

AWS has escalated the issue and they are working on it.
Posted Apr 29, 2021 - 12:40 PDT

Identified

We are currently receiving reports of delayed SMS delivery to Verizon customers. We have extended the time allowed for 2FA acceptance until Amazon has resolved the carrier issue on their side.
Posted Apr 29, 2021 - 11:27 PDT
This incident affected: Keeper Infrastructure (US Data Center) (Keeper Web Vault (US)).