EU Region login API errors

Incident Report for Keeper Status Page

Postmortem

On September 10 at 8:42 AM PDT, our monitoring detected elevated errors with the Auth API in the EU region. The issue was identified promptly and fully resolved by 8:49 AM PDT. Total impact duration was approximately 7 minutes.

Impact

  • Region affected: EU
  • Service affected: Authentication API
  • Customer impact: Customers in the EU experienced failed authentication attempts during the incident window.

Timeline (PDT)

  • 08:42 – Incident detected. Elevated Auth API errors in the EU region reported.
  • 08:43 – Engineering and DevOps teams engaged.
  • 08:46 – Root cause isolated to a Terraform-related configuration change involving a VPC endpoint.
  • 08:49 – Configuration change rolled back; Auth API errors resolved.

Root Cause

The outage was caused by a configuration change in our production tenant during an ongoing Terraform migration. As part of the migration, a new VPC endpoint was being added to production environments. During Terraform apply, a subnet association was also being created. A network disruption occurred between the creation of the VPC endpoint and the subnet association (behavior not seen in prior testing) leading to temporary Auth API connectivity failures in the EU region. A new Terraform migration plan has been created that eliminates the possibility of disruption.

Posted Sep 26, 2025 - 09:26 PDT

Resolved

The issue with Auth API errors in the EU region has been resolved. Additional details will be posted in the postmortem shortly.
Posted Sep 10, 2025 - 08:49 PDT

Identified

We are aware of Auth API errors in EU region and we have identified the isssue. The issue will be resolved shortly.
Posted Sep 10, 2025 - 08:42 PDT
This incident affected: Keeper Infrastructure (EU Data Center) (Keeper Web Vault (EU)).