SMS delivery issues for 2FA with Verizon network.
Incident Report for Keeper Security
Resolved
The 2FA delivery issue to Verizon has been resolved.
Posted Jul 27, 2020 - 21:21 PDT
Identified
We identified the reason that Verizon is not delivering SMS 2FA codes and we will be fixing it shortly.
Posted Jul 27, 2020 - 20:45 PDT
Investigating
Verizon SMS 2FA messages are experiencing a high failure rate. We are investigating the issue.
Posted Jul 27, 2020 - 19:49 PDT
This incident affected: Keeper Application Infrastructure (Keeper Web Vault, Keeper Web Vault (EU)).