EU vault intermittent loading
Incident Report for Keeper Status Page
Resolved
This incident has been resolved.
Posted Jun 16, 2020 - 03:04 PDT
Monitoring
Fix has been implemented, we will monitor the situation
Posted Jun 16, 2020 - 02:51 PDT
Update
We are continuing to investigate this issue.
Posted Jun 16, 2020 - 02:45 PDT
Investigating
We are currently investigating issues related to EU vault loading issues.
Posted Jun 16, 2020 - 02:45 PDT
This incident affected: Keeper Infrastructure (EU Data Center) (Keeper Web Vault (EU)).