Web Vault login in US (consumer accounts)
Incident Report for Keeper Status Page
Resolved
The issue has been resolved.
Posted Jan 29, 2023 - 22:25 PST
Identified
We are aware of login issues on the Web Vault for consumer accounts. This will be resolved shortly.
Posted Jan 29, 2023 - 22:21 PST
This incident affected: Keeper Infrastructure (US Data Center) (Keeper Web Vault (US)).