Vault Login errors - resolved

Incident Report for Keeper Status Page

Resolved

The issue has been resolved
Posted Mar 06, 2025 - 10:25 PST

Update

We are continuing to investigate this issue.
Posted Mar 06, 2025 - 10:24 PST

Investigating

We are investigating login errors and our team is currently working on the issue.
Posted Mar 06, 2025 - 10:23 PST
This incident affected: Keeper Infrastructure (US Data Center) (Keeper Web Vault (US), Keeper Admin Console (US)).