Site outage, team is investigating.
Incident Report for Keeper Status Page
Resolved
This incident has been resolved.
Posted Jul 22, 2020 - 14:10 PDT
Monitoring
Service has been restored. We are working through a software update and we're monitoring the situation. We'll continue to update the status page.
Posted Jul 22, 2020 - 13:58 PDT
Identified
The issue has been identified and the team is working on a solution.
Posted Jul 22, 2020 - 13:53 PDT
Investigating
We are currently working on the issue.
Posted Jul 22, 2020 - 13:45 PDT
This incident affected: End-User Client Applications (Keeper iOS, Keeper Android, Keeper Desktop App), Keeper Infrastructure (EU Data Center) (Keeper Web Vault (EU)), and Keeper Infrastructure (US Data Center) (Keeper Web Vault (US)).