File attachment downloads in EU Data Center
Incident Report for Keeper Security
Resolved
The issue has been resolved.
Posted Sep 16, 2021 - 03:06 PDT
Identified
We have identified an issue with file attachment downloads in EU Data Center, where the customer receives an error. The issue is being fixed momentarily.
Posted Sep 16, 2021 - 03:02 PDT
This incident affected: Keeper Infrastructure (EU Data Center) (Keeper Web Vault (EU)).