File attachment download errors for new uploaded files

Incident Report for Keeper Status Page

Postmortem

Incident Summary

In the US, EU, and AU regions, users experienced vault errors when attempting to download a file attachment immediately after adding it to a record. This issue affected only newly uploaded attachments in these three data center regions. The Gov, JP, and CA regions were not impacted.

Root Cause

During our investigation, we identified a discrepancy in how file attachment triggers were implemented across different regions. A recent Terraform change inadvertently removed the triggers responsible for moving file attachments in the US, EU, and AU regions, preventing newly uploaded files from being immediately available for download.

Resolution

We corrected the issue by restoring the missing triggers and applying the necessary changes. Additionally, any affected files were successfully moved to their intended locations.

Impact & Mitigation

  • No data loss occurred.
  • All impacted files were successfully resolved by our corrections.
  • We corrected the issue to prevent similar discrepancies in future infrastructure changes.

We apologize for any inconvenience and appreciate your patience while we resolved this issue.

Posted Mar 16, 2025 - 16:41 PDT

Resolved

The issue has been resolved. Additional information is in the postmortem report.
Posted Mar 13, 2025 - 14:15 PDT

Identified

Some users are receiving errors when downloading file attachments. We are working on resolution.
Posted Mar 13, 2025 - 12:17 PDT
This incident affected: Keeper Infrastructure (US Data Center) (Keeper Web Vault (US)).