Firefox browser extension issue with 16.6.0
Incident Report for Keeper Status Page
Resolved
Mozilla has released version 16.6.1. Visit the Firefox Add-ons screen and check for updates to install.
Posted Aug 21, 2023 - 05:19 PDT
Monitoring
We have pushed a new version to Mozilla (16.6.1) which is pending review to address autofill issues on Firefox.
Posted Aug 17, 2023 - 22:33 PDT
Identified
We are aware of login and filling errors with the KeeperFill browser extension on Firefox. This issue is randomly occurring during initialization of the extension. Restarting Firefox when this occurs may temporarily resolve the issue. We have pushed a new version to Mozilla (16.6.1) which is pending review. Mozilla should release the update within 24 hours.
Posted Aug 16, 2023 - 11:24 PDT
This incident affected: End-User Client Applications (Keeper Browser Extensions).