Vault errors in EU region
Incident Report for Keeper Status Page
Postmortem

At approx. 6:30AM PST our engineers were notified that customers were receiving a high number of errors in the EU region. After analysis, we found that our NGINX infrastructure was throwing errors for some users. We resolved the issue fully by 7AM PST however we understand upon further analysis of our logs that some customers were affected off and on for a couple of hours leading up to the alarm threshold. We have implemented the updates to NGINX to resolve this issue, and we are implementing additional improvements in our error detections to ensure we can react faster to elevated errors.

Keeper Desktop software supports “work offline” capabilities to ensure that users can access their vault in any offline situation. More info on “work offline” mode is available here:

https://docs.keeper.io/enterprise-guide/vault-offline-access

Posted Feb 14, 2022 - 23:10 PST

Resolved
The issue has been resolved. We are investigating root cause and will update this event later this morning.
Posted Feb 14, 2022 - 07:00 PST
Identified
We have located the source of the issue in our EU infrastructure, and engineers are currently working on the resolution.
Posted Feb 14, 2022 - 06:53 PST
Investigating
We are investigating 502 errors in the EU region.
Posted Feb 14, 2022 - 06:28 PST
This incident affected: Keeper Infrastructure (EU Data Center) (Keeper Web Vault (EU), Keeper Admin Console (EU)).