Slow login
Incident Report for Keeper Security
Resolved
This has been resolved
Posted May 20, 2020 - 06:53 PDT
Investigating
The Web Vault is experiencing slower than normal login. We are looking into the cause.
Posted May 20, 2020 - 06:48 PDT
This incident affected: Enterprise Applications (Keeper Admin Console) and Keeper Application Infrastructure (Keeper Web Vault).