Web Application Service Interruption
Incident Report for Keeper Security
Postmortem

Dear Keeper Customer,

This morning, we experienced an interruption to our Web Applications. This was caused by an intermittent overload in our servers at AWS. During this period, some users experienced difficulties logging into the Keeper Web Applications or slower operating speeds. This issue has been resolved.

Web Vault:

Please refresh/reload the Web Vault on your web browser

Desktop App:

Please update your application to version 14.2.1 by either downloading the update from our website download page or restart the application, wait a few minutes for the update to automatically download, and then restart the application again.

Mobile applications were partially affected by this issue, but no update is required.

In the future, you can monitor and subscribe to Keeper’s system status updates from our Status Page.

We apologize for any inconvenience this may have caused.

Thank you,

Keeper Team

Posted 6 months ago. Jan 22, 2019 - 11:42 PST

Resolved
This incident has been resolved.

Web Vault:
Please refresh/reload the Web Vault on your web browser

Desktop App:
Please update your application to version 14.2.1 by either downloading the update from our website download page (https://keepersecurity.com/download) or restart the application, wait a few minutes for the update to automatically download, and then restart the application again.

Mobile applications were unaffected by this issue.
Posted 6 months ago. Jan 22, 2019 - 10:59 PST
Update
We have resolved the issue with our software that was causing the spike in activity and slowing down requests. More details will be posted shortly.
Posted 6 months ago. Jan 22, 2019 - 10:56 PST
Update
We are continuing to investigate this issue.
Posted 6 months ago. Jan 22, 2019 - 10:55 PST
Update
We are still working on this issue. iOS, Desktop and Android apps (in offline mode) are still accessible.
Posted 6 months ago. Jan 22, 2019 - 09:55 PST
Update
We have confirmed that the issue is caused by increased load in application servers within Amazon AWS. We are working on resolving the issue.
Posted 6 months ago. Jan 22, 2019 - 09:45 PST
Update
We are continuing to investigate this issue.
Posted 6 months ago. Jan 22, 2019 - 09:27 PST
Update
Our DevOps team is still investigating the root cause of the issue.
Posted 6 months ago. Jan 22, 2019 - 09:21 PST
Update
We have published an update to the Web Vault to address this issue. Please reload your Web Vault (CTRL+R) and login to your vault.
Posted 6 months ago. Jan 22, 2019 - 08:30 PST
Update
While we are working on this issue, please use your Desktop App in offline mode or mobile app to access your Keeper vault. This will be resolved shortly.
Posted 6 months ago. Jan 22, 2019 - 07:54 PST
Investigating
We have identified the issue which is causing instability in the Web Vault and we are working on a solution. We'll keep you updated. Push notifications are causing a loop and generating application errors. A fix is in progress.
Posted 6 months ago. Jan 22, 2019 - 07:53 PST
This incident affected: Keeper Application Infrastructure (Keeper Web Vault).