AWS outage affecting KeeperPAM connections and scheduled rotations

Incident Report for Keeper Status Page

Resolved

Clearing this alert as most AWS services are restored.
Posted Oct 20, 2025 - 13:31 PDT

Identified

There are intermittent connectivity issues due to the AWS outage in US-EAST-1 affecting KeeperPAM cloud connections, scheduled rotations and discovery operations.
Posted Oct 20, 2025 - 10:25 PDT
This incident affected: Enterprise Application Components (Installed or On-Prem) (Keeper Secrets Manager, Keeper Connection Manager).