SMS delivery in US Data Center
Incident Report for Keeper Status Page
Resolved
Amazon has resolved the issue.
Posted Jun 02, 2023 - 16:21 PDT
Update
AWS acknowledged that they are having some SMS delivery problems. We have routed SMS delivery to email temporarily.
Posted Jun 02, 2023 - 15:45 PDT
Identified
Amazon AWS is having an SMS delivery outage. They are working on it. We have temporarily routed SMS codes to email. Please check your email to receive the code.
Posted Jun 02, 2023 - 15:45 PDT
Investigating
We are investigating SMS delivery issues in the US Data Center.
Posted Jun 02, 2023 - 15:23 PDT
This incident affected: End-User Client Applications (Keeper iOS, Keeper Android) and Keeper Infrastructure (US Data Center) (Keeper Web Vault (US)).