Desktop App "Please Update" message.
Incident Report for Keeper Security
Postmortem

The issue experienced this morning with the Keeper Web Vault and Desktop Application required a software update. The Web Vault was updated by simply reloading the page, however the Desktop App required an application version update according to our standard release procedure.

Please update your application to version 14.2.1 by either downloading the update from our website download page or restart the application, wait a few minutes for the update to automatically download, and then restart the application again.

Keeper Team

Posted 4 months ago. Jan 22, 2019 - 12:51 PST

Resolved
Desktop App update 14.2.1 is live. Please close the app, restart, check the version, if not 14.2.1, close and open it again to apply the update. If the update is not received, you can also install the latest version from our website at:
https://keepersecurity.com/download
Posted 4 months ago. Jan 22, 2019 - 12:49 PST
Identified
We are aware that the Desktop App v14.2 is informing users to update their application. We will be addressing this issue in a few minutes. To bypass this message temporarily, you can login with Wi-Fi or network disabled (offline mode). You can also login to the Web Vault:
https://keepersecurity.com/vault
Posted 4 months ago. Jan 22, 2019 - 12:07 PST
This incident affected: End-User Client Applications (Keeper Desktop App).