SSO Login Issue
Incident Report for Keeper Status Page
Postmortem

Keeper’s new SSO certificate has been live since Aug 8, however a change made in the SAML request to send the new cert inadvertently caused some identity provider configurations to reject the request. Updating the SP Cert on the identity provider would have quickly resolved this for all affected customers, but we went ahead and reverted the change on our side.

As a reminder, the old SSO Cloud certificate will expire on Aug 17th which will affect some identity providers. We recommend that customers using SSO Connect Cloud proactively update the SP Cert on the identity provider before the 17th per the instructions below:

https://docs.keeper.io/release-notes/enterprise/other/sso-certificate-renewal-2022

Posted Aug 09, 2022 - 14:19 PDT

Resolved
The SSO issue has been resolved for those affected. We'll post information in the postmortem page.
Posted Aug 09, 2022 - 13:56 PDT
Update
A change was pushed live which inadvertently affected several customers who are using certain IdP configurations. The change is being reverted within 15 minutes.
Posted Aug 09, 2022 - 13:21 PDT
Update
We are continuing to work on a fix for this issue.
Posted Aug 09, 2022 - 13:20 PDT
Identified
We are aware of an SSO login issue for some customers which will be resolved shortly.
Posted Aug 09, 2022 - 13:20 PDT
This incident affected: Enterprise Application Components (Installed or On-Prem) (Keeper SSO Connect).