Duo Push in US region
Incident Report for Keeper Status Page
Postmortem

The Keeper engineering team has been researching the cause for recent Duo Push issues. Our investigation has resulted in the identification of a couple issues. The description is below:

  1. The Duo Push services also have a direct dependency on the Keeper Push services which utilize websocket communication from the Keeper backend to the client device.
  2. We determined that scaling additional instances of our push services was necessary to meet the growing usage of Duo and general push features across the Keeper end-user client apps
  3. Scaling the backend instances immediately resolved the latency and the intermittent issues encountered by users.
  4. In addition, we met with the Duo team, revisited our Duo integration code and we decided to rewrite some portions of the integration to reduce the number of dependencies and asynchronous processes. This is planned for release by December 20, 2023.
Posted Dec 14, 2023 - 22:53 PST

Resolved
Duo Push issues in the US region have been resolved. It may be necessary to reload the web vault page or restart the web browser.
Posted Dec 13, 2023 - 10:19 PST
Investigating
We are investigating intermittent Duo Push issues in the US region. Hard refreshing the browser window appears to mitigate the issue.
Posted Dec 13, 2023 - 09:29 PST
This incident affected: Keeper Infrastructure (US Data Center) (Keeper Web Vault (US)) and End-User Client Applications (Keeper Browser Extensions).