Keeper website homepage
Incident Report for Keeper Status Page
Postmortem

Keeper updated all US data center endpoints with new certificates signed by Amazon AWS, along with several underlying infrastructure improvements. There was a few minutes where the Keeper homepage was not accessible, and the issue was resolved by the DevOps team.

Posted Mar 02, 2022 - 20:59 PST

Resolved
The www.keepersecurity.com website homepage was throwing errors for a few minutes, and the issue has been resolved. Vault login was not affected. Please note that the Keeper certificates are now signed by Amazon AWS. Front-end IP addresses have also changed in the US region.
Posted Mar 02, 2022 - 20:30 PST