GovCloud Admin Console login with ARAM permissions
Incident Report for Keeper Status Page
Postmortem

The GovCloud DevOps team uses automated infrastructure deployment systems via Terraform to manage all environments. A change was made to subnet VPC routing which inadvertently caused connectivity issues between certain backend services and a specific Redshift cluster.

This issue affected admins on the Keeper Admin Console who have ARAM permissions applied to their role policies. Delegated admins without reporting permissions were not affected. Vault login and other client-side vault applications were not affected.

Recent improvements to the Vault and Admin Console backend APIs masked the issue for the automated detection systems which would have immediately flagged the error and alerted the DevOps team. We have resolved the infrastructure route and updated the monitoring systems to take this into account and will continue to monitor for any future issues.

Posted Aug 30, 2023 - 08:15 PDT

Resolved
The issue has been resolved. Console login to GovCloud for users with ARAM reporting administrative functions has been restored.
Posted Aug 30, 2023 - 07:50 PDT
Update
We are continuing to work on a fix for this issue.
Posted Aug 30, 2023 - 07:14 PDT
Identified
We have identified an issue affecting users on the Admin Console in the GovCloud region who have administrative rights over Advanced Reporting & Alerts module (ARAM).
Posted Aug 30, 2023 - 07:03 PDT
This incident affected: Keeper Infrastructure (GovCloud) (Keeper Admin Console (GovCloud)).