SMS Code Delivery in US (Verizon)
Incident Report for Keeper Status Page
Resolved
Amazon AWS appears to have resolved the issue on their side. As always, we recommend using a Yubikey or software based TOTP code for 2FA such as Google Authenticator or Duo to access your vault.
Posted Feb 26, 2021 - 07:26 PST
Investigating
We are investigating SMS delivery issues with US Carriers (Verizon). We have opened a ticket with Amazon AWS and will post updates as soon as possible. If you need to switch to a different 2FA method, please contact support or your Keeper Administrator.
Posted Feb 26, 2021 - 07:07 PST
This incident affected: Keeper Infrastructure (US Data Center) (Keeper Web Vault (US)).