Email delivery issues in EU Data Center
Incident Report for Keeper Status Page
Resolved
This issue has been resolved.
Posted Sep 21, 2021 - 16:56 PDT
Update
We have resolved the issue and we're working with Amazon SES to restore delivery in EU
Posted Sep 21, 2021 - 14:49 PDT
Identified
We are investigating an issue with email delivery in the EU region.
Posted Sep 21, 2021 - 08:06 PDT
This incident affected: Keeper Infrastructure (EU Data Center) (Keeper Web Vault (EU), Keeper Admin Console (EU)).