Login errors in US region

Incident Report for Keeper Status Page

Resolved

The issue has been resolved.
Posted Feb 23, 2025 - 20:28 PST

Investigating

We are currently investigating login errors in the US region.
Posted Feb 23, 2025 - 19:54 PST
This incident affected: Keeper Infrastructure (US Data Center) (Keeper Web Vault (US), Keeper Admin Console (US)).