Firefox extension update 16.6.2 - Resolved

Incident Report for Keeper Status Page

Resolved

Version 16.6.2 has been published by Mozilla and it is available for update from the Firefox add-on store
https://addons.mozilla.org/en-US/firefox/addon/keeper-password-manager/?src=search
Posted Aug 24, 2023 - 04:08 PDT

Monitoring

We have published version 16.6.2 to the Mozilla store and await review. This update resolves all Firefox related issues.
Posted Aug 22, 2023 - 08:22 PDT

Identified

If you encounter any problems with Firefox extension 16.6.1 after restarting your browser, please uninstall and reinstall the extension. Another update 16.6.2 is being created to address this issue.
Posted Aug 21, 2023 - 15:16 PDT
This incident affected: End-User Client Applications (Keeper Browser Extensions).