Verizon SMS code delivery delays
Incident Report for Keeper Status Page
Resolved
Amazon has resolved the issue with Verizon. As always, we recommend using Google Authenticator or other TOTP methods instead of SMS for reliable and secure 2FA.
Posted Jan 19, 2021 - 12:29 PST
Identified
Verizon users in the US are experiencing delayed SMS codes. If you need immediate access, please contact Keeper support or your Keeper Administrator to help disable 2FA and convert to another method such as Google Authenticator or Microsoft Authenticator. More info on changing TOTP methods can be found here:

https://docs.keeper.io/user-guides/web-vault#google-and-microsoft-authenticator-totp-setup

We have reached out to the Amazon AWS (SMS provider) and will update this page once the issue is resolved.
Posted Jan 19, 2021 - 09:05 PST
This incident affected: Keeper Infrastructure (US Data Center) (Keeper Web Vault (US)).