Vault loading speed in US region
Incident Report for Keeper Status Page
Resolved
The issue has been resolved. We will continue monitoring.
Posted Nov 02, 2020 - 06:33 PST
Identified
Keeper DevOps team is investigating Vault loading issues in the US region.
Posted Nov 02, 2020 - 06:27 PST
This incident affected: Keeper Infrastructure (US Data Center) (Keeper Security Website (US), Keeper Web Vault (US)).