Prompt for update on Browser Extension
Incident Report for Keeper Status Page
Postmortem

Keeper’s backend has a system in place to control which end-user application versions are allowed to authenticate. During our publishing process of version 16.4.14 we mistakenly blocked version 16.4.13 application during one of the 10-minute update cycles. We have corrected the error in the process which caused the issue.

Posted Apr 03, 2023 - 09:31 PDT

Resolved
We are aware that some users are receiving a prompt to update the browser extension upon logging in. This has been resolved and will automatically clear out in a few minutes.
Posted Apr 03, 2023 - 09:11 PDT
This incident affected: End-User Client Applications (Keeper Browser Extensions).