Email delivery in US region due to AWS US-EAST outage

Incident Report for Keeper Status Page

Resolved

All Keeper email delivery services in US-EAST-1 were restored around 4AM PST.
Posted Oct 20, 2025 - 08:17 PDT

Identified

SMS delivery services have been restored, but AWS Lambda is still down which affects our email delivery of device approvals. We recommend using the "Keeper Push" or TOTP method of device approval.
Posted Oct 20, 2025 - 03:00 PDT

Investigating

AWS is reporting errors in the US-EAST region that are affecting multiple services, affecting email and SMS delivery which impacts Keeper device approvals.

The AWS Service Health dashboard can be monitored here:
https://health.aws.amazon.com/health/status
Posted Oct 20, 2025 - 02:20 PDT
This incident affected: Keeper Infrastructure (US Data Center) (Keeper Web Vault (US), Keeper Admin Console (US)).