Duo push and push notifications
Incident Report for Keeper Status Page
Resolved
Issue is resolved. We will continue monitoring.
Posted Oct 11, 2020 - 11:37 PDT
Monitoring
The Duo issue appears resolved however we are investigating the cause and monitoring the situation.
Posted Oct 11, 2020 - 10:30 PDT
Investigating
We are investigating an issue with Duo Push failures when logging into Keeper. Please use "text message" Duo or manual code entry option while we investigate the cause. The issue appears related to push notification responses.
Posted Oct 11, 2020 - 10:23 PDT
This incident affected: Keeper Infrastructure (EU Data Center) (Keeper Web Vault (EU)) and Keeper Infrastructure (US Data Center) (Keeper Web Vault (US)).