Known issues with Chrome Extension v16.4.4
Incident Report for Keeper Status Page
Postmortem

Keeper maintains multiple Chrome extensions on the Google Chrome Store. One of the reasons for this is to stage our rollouts to different sized populations of users. Between the 2nd and 3rd stage of deployment, a bug was introduced due to a packaging issue which caused Autofill to stop working for that population. Once the issue was discovered, the Keeper browser extension team immediately identified and resolved the issue. The release was posted to the Google Chrome store within 1 hour of notification. Google Chrome Store’s policy requires a member of their app review team to manually approve all submissions. Google approved the release at 10:47PM PST.

As a result of this issue, the engineering management and QA team have made an improvement to our release process to prevent this type of issue from occurring in the future. If you have any questions please contact us at https://www.keepersecurity.com/support.html

Posted Jul 14, 2022 - 00:06 PDT

Resolved
The Chrome browser extension has been published by Google. All users will automatically receive the update. If you installed the alternate Keeper extension, you may continue using it. Keeper maintains multiple browser extensions on the Chrome Store and they are always updated to the latest version.
Posted Jul 13, 2022 - 23:42 PDT
Update
We are aware of an Autofill issue with Chrome extension 16.4.4. Edge, Safari and Firefox are not affected. We have published a fix to the Google Chrome store and we're currently waiting for them to approve the update. We expect the fix to go live within 24 hours.

For a temporary workaround, please follow the steps below:

1. Go to Window > Extensions and remove the current extension
2. Install the version from the link below:
https://chrome.google.com/webstore/detail/kbedblbpfmeicfpadihimgombbafaeeh
3. "Pin" the new extension to make the icon visible

Important: Ensure only one Keeper extension is installed at a time.

For customers who roll out with group policy, you can push the extension listed above.
Posted Jul 13, 2022 - 06:32 PDT
Monitoring
We are aware of an Autofill issue with Chrome extension 16.4.4. A fix has been posted awaiting approval from the Google Chrome store.
Posted Jul 13, 2022 - 05:56 PDT
This incident affected: End-User Client Applications (Keeper Browser Extensions).