SMS 2FA delivery in the US data center
Incident Report for Keeper Status Page
Resolved
Amazon AWS has resolved their SMS delivery issue to Verizon customers.
Posted Sep 28, 2023 - 14:13 PDT
Update
SMS delivery to Verizon is currently affected by an AWS issue. We have temporarily routed SMS 2FA delivery to customer email while AWS researches the issue on their side. Please check your email to receive your SMS 2FA codes. We will update the status page when the issue has been resolved.
Posted Sep 28, 2023 - 12:41 PDT
Identified
SMS delivery to Verizon is currently affected by an AWS issue. We have temporarily routed SMS 2FA delivery to customer email while AWS researches the issue on their side. Please check your email to receive your SMS 2FA codes. We will update the status page when the issue has been resolved.
Posted Sep 28, 2023 - 12:26 PDT
Investigating
We are investigating SMS 2FA delivery in the US data center
Posted Sep 28, 2023 - 12:06 PDT
This incident affected: End-User Client Applications (Keeper iOS, Keeper Android, Keeper Desktop App) and Keeper Infrastructure (US Data Center) (Keeper Web Vault (US), Keeper Admin Console (US)).