Resolved: KeeperPAM Connection Errors in US Data Center

Incident Report for Keeper Status Page

Postmortem

At 9:05 AM PST, alerts were triggered for issues affecting KeeperPAM connections managed through Keeper’s ECS deployments in the US-EAST region. There were no recent changes to the application or environment.

Investigation identified a low-level concurrency bug in the Keeper EPM service that caused request failures under high simultaneous load. These failures led to instability in the ECS services supporting KeeperPAM connections.

As a temporary mitigation, we blocked the error condition, restoring KeeperPAM connectivity by approximately 1:00 PM PST.

The engineering team then developed and deployed an updated Keeper Router version to address the underlying issue and prevent EPM agents from triggering server errors. The fix was fully validated by 3:00 PM PST, at which point all KeeperPAM services were stable and operating normally.

Posted Mar 23, 2026 - 16:19 PDT

Resolved

The issue has been resolved. See postmortem page with additional details.
Posted Mar 23, 2026 - 14:45 PDT

Monitoring

A fix has been implemented and we are monitoring the KeeperPAM connection stability. We will update this case with additional details soon.
Posted Mar 23, 2026 - 13:03 PDT

Identified

We have identified the cause of the KeeperPAM connection errors which are related to a networking issue within the AWS ECS environment. We are actively troubleshooting with the AWS support team and will update the ticket as soon as there is a status update.
Posted Mar 23, 2026 - 11:47 PDT

Investigating

We are investigating errors in establishing KeeperPAM connections in the US Data Center.
Posted Mar 23, 2026 - 10:07 PDT
This incident affected: Keeper Infrastructure (US Data Center) (Keeper Web Vault (US)).