SMS delivery in US

Incident Report for Keeper Status Page

Resolved

The issue is resolved.
Posted Mar 29, 2022 - 20:03 PDT

Identified

We have identified the issue, waiting on Amazon AWS for resolution. SMS 2FA is being routed to email temporarily.
Posted Mar 29, 2022 - 19:49 PDT

Investigating

We are currently investigating an issue with our SMS delivery provider at Amazon AWS. Until this is resolved, we are routing SMS codes to email.
Posted Mar 29, 2022 - 19:13 PDT
This incident affected: Keeper Infrastructure (US Data Center) (Keeper Web Vault (US), Keeper Admin Console (US)).